Results 1 to 2 of 2

Thread: Amazing Grace

  1. #1

    Default Amazing Grace

    Hi
    Just registered but the forum looks quiet. Our 385 Amazing Grace ( previously Glamour Puss) is in Carthagena and we hope to get to Sicily this season.
    The manual bilge pump on starboard side is not working. Any advice on how to access and likely fault appreciated.

  2. #2
    Join Date
    Dec 2008
    Location
    Rutland or afloat
    Posts
    14

    Default Re: Amazing Grace

    Hi littlefred, welcome to the forum.
    I too have a BB385, Footloose, currently in Greece. I thought I knew the boat pretty well, until you posted your question. I’ve just been looking and you’re right, there is no obvious access route. However, if you first attach a messenger line to the pump, then remove its mounting screws from the cockpit, it may be possible to withdraw it by pulling on its suction hose from either the cupboard under the wash basin or access plate in wardrobe, depending on your particular configuration. Use the messenger line to pull it back into its location after effecting a repair. The pump is pretty basic and kits with valves and diaphragm are available. It’s unlikely you’ll need more than that.
    One other point, if the pump has not been used for a while the valves may not seal properly until they get wet again. The pump is mounted nearly 2 meters above its strum box. Quite a lift! I would suggest that you pull the inlet hose with its strum box out of the sump, raise it as high as possible and pour water into it and then try pumping. The reduced head may just be enough to get it going again.
    If you are successful, please post your result.
    Take care.

    Mike.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •